Viewfinder Goes Black While Shooting

Welcome to Our Canon RF Shooters Community Forum

We'd love to welcome you on board, join today!

Jake Shoots Birds

Well Known Member
Pro Member
Pro Member
Followers
3
Following
0
Joined
Aug 29, 2021
Posts
251
Likes Received
244
Name
Jake Kurdsjuk
City/State
Washington, NJ
While shooting today I was using Electronic-First Curtain and high burst rate when I experienced multiple occurrences of the viewfinder going black while shooting. Sometimes at the beginning of the burst, sometimes after 10-20 frames were shot. It would go black for anywhere between 2-5 frames and then come back. The shots taken during those times were fine, it was just the viewfinder that went black. I pinged my pro rep friend and he said he'd never heard of anyone experiencing it and asked if I was using a 3rd party battery. I was, but I'd been using those same batteries for months without ever experiencing this.

Anyone here ever have this happen?
 

behindthelens88

Active Member
Pro Member
Pro Member
Followers
1
Following
1
Joined
Feb 5, 2022
Posts
30
Likes Received
55
Name
Justin
this can actually happen from using a cheaper memory card , so the memory card wont be able to play keep up with the camera firing first. had same issue with sandisk memory card the better quality one or so i thought so i switched to prograde and never a problem and i also write it to my CF mini style B card instead of going to my regular style memory card which also does make a diffrence
 

Hali

Well Known Member
Pro Member
Pro Member
Followers
21
Following
9
Joined
Apr 19, 2021
Posts
558
Likes Received
1,116
Name
Hali
City/State
Rhode Island, US
CC Welcome
  1. Yes
I've been having this problem since I got my 100-500. I think it's the battery and the card. I am ditching my third party batteries. I thought my Sony tough card was pretty good but I hear it's not, so I'm going to get a prograde one and see if that helps.
 

Jake Shoots Birds

Well Known Member
Pro Member
Pro Member
Followers
3
Following
0
Joined
Aug 29, 2021
Posts
251
Likes Received
244
Name
Jake Kurdsjuk
City/State
Washington, NJ
Thanks, folks. I've got a killer card, so it's got to be the battery. I have 4 off-brand batteries (and 2 Canon) and never had an issue before, so I marked the one that gave me an issue and I won't use it again until I'm simply testing it to see if it happens again. I stuck a Canon battery back in yesterday and zero issues. I'll save the others for the R6 since I rarely shoot in continuous mode on that one.
 

Hali

Well Known Member
Pro Member
Pro Member
Followers
21
Following
9
Joined
Apr 19, 2021
Posts
558
Likes Received
1,116
Name
Hali
City/State
Rhode Island, US
CC Welcome
  1. Yes
So, I went out and bought a ProDigital card that is considered top of the line. Opened it, put it in the camera, and haven't had a chance to go shoot. Today I saw (Thanks Timothy and RedCobra for the heads up) that Canon realized that the problem was them, not the card, not the batteries and posted a FW update. Here's to hoping that really works. Now I have 3 128 GB CF Express cards, lol, I just have to go out and find something fun to shoot.
 

* Remove Ads by Becoming a   Pro Member   *

Doug B

Newcomer
Followers
1
Following
0
Joined
Nov 22, 2022
Posts
4
Likes Received
4
Name
Doug Bottrell
My new R5 is blacking out both EVF and rear screen. I have a fully charged Canon issued battery and a new CFExpress 128Mb Card.
Any suggestions to rectify would be appeciated.
 

Timothy Mayo

Administrator
Pro Member
Pro Member
Followers
110
Following
20
Joined
Jan 20, 2021
Posts
879
Likes Received
767
Name
Tim
City/State
Shropshire
CC Welcome
  1. Yes
My new R5 is blacking out both EVF and rear screen. I have a fully charged Canon issued battery and a new CFExpress 128Mb Card.
Any suggestions to rectify would be appeciated.
Is it only happening with the Sigma lens Doug or native Canon RF lenses as well? Which Sigma lens is it and which adapter are you using?
 

Doug B

Newcomer
Followers
1
Following
0
Joined
Nov 22, 2022
Posts
4
Likes Received
4
Name
Doug Bottrell
Is it only happening with the Sigma lens Doug or native Canon RF lenses as well? Which Sigma lens is it and which adapter are you using?
I have a new Integral Ultima Pro X2 CFExpress card
While shooting today I was using Electronic-First Curtain and high burst rate when I experienced multiple occurrences of the viewfinder going black while shooting. Sometimes at the beginning of the burst, sometimes after 10-20 frames were shot. It would go black for anywhere between 2-5 frames and then come back. The shots taken during those times were fine, it was just the viewfinder that went black. I pinged my pro rep friend and he said he'd never heard of anyone experiencing it and asked if I was using a 3rd party battery. I was, but I'd been using those same batteries for months without ever experiencing this.

Anyone here ever have this happen?
I have a new Integral Ultima Pro X2 CFExpress memory card and the new supplied, fully chsrged Canon battery. The black out has occured with my EF-S 18mm - 55mm lens, 100mm - 400mm MkII lens, and the Sigma 150mm - 600mm Contempory lens. I have the standard EF - R Converter.
Thanks for your input.
 

Doug B

Newcomer
Followers
1
Following
0
Joined
Nov 22, 2022
Posts
4
Likes Received
4
Name
Doug Bottrell
I have a new Integral Ultima Pro X2 CFExpress card

I have a new Integral Ultima Pro X2 CFExpress memory card and the new supplied, fully chsrged Canon battery. The black out has occured with my EF-S 18mm - 55mm lens, 100mm - 400mm MkII lens, and the Sigma 150mm - 600mm Contempory lens. I have the standard EF - R Converter.
Thanks for your input.
Not sure what to make of this issue now? Before taking it back to the retailer for comment, I triad the various lens' again, in mechanical and electronic mode, and full frame and crop frame. I also put my 1.4 Converter Mk III on the EF 100mm - 400mm. The only issue I could raise, was the auto focus was a deal slower with the Sigma 150mm - 600mm. Having seen various video's on thie latter's compatibility with the 'R' series camera's, it looks like I will need to have the Sigma lens re-calibrated!!!!
I feel an RF 100mm - 500mm swap coming on... sincere thanks for the help and advise from those who addressed my issue. Hopefully it is just the 3rd party lens and I can relax and not worry about a blnk screen/EVF again. By for now 👍
 

Latest reviews

  • Canon Mount Adapter EF-EOS R
    5.00 star(s)
    Canon Mount Adapter EF-EOS R
    Use this successfully with EFS18-55 and EFS55-250 on both RP and R10. Quick focusing response in either camera. Small enough to fit in a pants...
    • TandemYardsPhotography
  • Canon Control Ring Mount Adapter EF-EOS R
    5.00 star(s)
    Canon Control Ring Mount Adapter EF-EOS R
    I have the standard and the control ring adaptor , other than the control ring the pro’s are the same but the ability to easily customise the...
    • Rob2563
  • Prime Canon RF 85mm F1.2L USM
    5.00 star(s)
    First RF PRIME lens
    This is definitely one of a great lens. I recommend it for people who does portrait photography. I use them in Weddings and Events if I need to...
    • sinbadking
  • Prime Canon RF 600mm F11 IS STM
    5.00 star(s)
    The 600mm f/11 is a viable option not just something to be 'settled for' by people who wanted more
    The tendency for reviewers and 'experts' is to point out that the 600mm f/11 is not as long as the 800 and not as fast as the big and expensive EF...
    • dougsmit
  • Kolari EF-EOS R Drop-In Filter Mount Adapter
    5.00 star(s)
    Review of the Kolari EF-EOS R Drop-In Filter Mount Adapter and drop-in filters.
    After waiting months with no success for delivery of a similar adapter system from a another 3rd-party maker, this spring I purchased the Kolari...
    • Paulie G

* Remove Ads by Becoming a   Pro Member   *

Top